
<!DOCTYPE html>
<html lang="en">
<head><meta charset="utf-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge" /><meta name="viewport" content="width=device-width, initial-scale=1" /><title>
	St. Casimir Church, community make sure Willson School families have holiday dinners
</title><link rel="alternate" type="application/rss+xml" title="Subscribe to the Freshwater Cleveland RSS feed!" href="https://feeds.feedburner.com/FreshwaterCleveland" />
<link rel="shortcut icon" href="/images/favicon.ico" />
<link rel="icon" type="image/png" href="/images/favicon.png" />
<link rel="canonical" href="https://www.freshwatercleveland.com/street-level/CasimirHams111522.aspx" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.freshwatercleveland.com/street-level/CasimirHams111522.aspx" />
<meta property="og:site_name" content="Cleveland - Freshwater Media" />
<meta property="og:title" content="St. Casimir Church, community make sure Willson School families have holiday dinners" />
<meta property="og:image" content="https://www.freshwatercleveland.com/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg" />
<meta property="og:image:width" content="750" />
<meta property="og:image:height" content="500" />
<meta property="og:description" content="" />
<meta property="fb:admins" content="1054316675" />
<meta property="fb:admins" content="674682725" />
<meta property="fb:admins" content="1212364057" />
<meta property="fb:app_id" content="148315665262637" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@FreshWaterCLE" />
<meta name="twitter:title" content="St. Casimir Church, community make sure Willson School families have holiday dinners" />
<meta name="twitter:url" content="https://www.freshwatercleveland.com/street-level/CasimirHams111522.aspx" />
<meta name="twitter:image" content="https://www.freshwatercleveland.com/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/css/bootstrap.min.css">
<link rel="stylesheet" href="https://unpkg.com/flickity@2.2.1/dist/flickity.min.css">
<link rel="stylesheet" href="https://unpkg.com/flickity-fullscreen@1.1.1/fullscreen.css">
<link rel="stylesheet" type="text/css" href="/css/combined.min.css?v=637965269571458190" />
<link rel="stylesheet" type="text/css" href="/css/site.css?v=637178839140000000" />
<script type="text/javascript" src="/script/combined.min.js?v=637965273001123058"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js"></script>
<script type="text/javascript">OA_zones = {'Footer 01':234,'Footer 02':235,'Footer 03':236,'Footer 04':237,'Footer 05':238,'Footer 06':239,'Footer 07':240,'Footer 08':241,'Footer 09':242,'Footer 10':243,'Footer 11':244,'Footer 12':245,'Leaderboard 2':6872,'Leaderboard 3':6873,'Masthead Leaderboard':6863,'Rectangle 1':6867,'Rectangle 2':6868,'Rectangle 3':6869,'Rectangle 4':6870,'Rectangle 5':6871,'Rectangle Html 1':6864,'Rectangle Html 2':6865,'Rectangle Html 3':6866};
</script>
<script type='text/javascript' src='https://dsx.issuemediagroup.com/www/delivery/spcjs.php?Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success'></script>
<meta name="description" content="" />
<meta name="keywords" content="St. Casimir Church, Willson School, CMSD" />
<script>(function (p, i, c, o) { var n = new Event("pico-init"); i[p] = i[p] || function () { (i[p].queue = i[p].queue || []).push(arguments) }, i.document.addEventListener("pico-init", function (e) { var t = i.Pico.getInstance(e, { publisherId: o, picoInit: n }, i); t.handleQueueItems(i[p].queue), i[p] = function () { return t.handleQueueItems([arguments]) } }, !1); var e = i.document.createElement("script"), t = i.document.getElementsByTagName("script")[0]; e.async = 1, e.src = c, e.onload = function (e) { return i.Pico.getInstance(e, { publisherId: o, picoInit: n }, i) }, t.parentNode.insertBefore(e, t) })("pico", window, "https://gadget.pico.tools/wrapper.min.js", "fa36d4ff-c158-4da4-95c3-0400a0151a56");</script>
<script>
    var isRootSite = true;
</script>
<script>
    var g4_analytics_enabled = true;
    var universal_analytics_enabled = true;
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-QPHMBD3C3E"></script>
<script>
    window.dataLayer = window.dataLayer || [];
    function gtag() { dataLayer.push(arguments); }
    gtag('js', new Date());

    gtag('config', 'G-QPHMBD3C3E', { 'page_location': 'https://www.freshwatercleveland.com/street-level/CasimirHams111522.aspx', 'site_name': 'Freshwater Cleveland', 'site_domain': 'www.freshwatercleveland.com', 'site_path': '/street-level/CasimirHams111522.aspx' });

    
    gtag('config', 'G-8M4MNT5MC5', { 'page_location': 'https://www.freshwatercleveland.com/street-level/CasimirHams111522.aspx', 'site_name': 'Freshwater Cleveland', 'site_domain': 'www.freshwatercleveland.com', 'site_path': '/street-level/CasimirHams111522.aspx' });
    
</script>
<script>
    var google_domain = 'www.freshwatercleveland.com';
    var google_cx = '006919356486600035371:mpcbvutfynu';
    var google_cof = 'FORID:11';
    var site_base_url = '';

    (function (i, s, o, g, r, a, m) {
        i['GoogleAnalyticsObject'] = r; i[r] = i[r] || function () {
            (i[r].q = i[r].q || []).push(arguments)
        }, i[r].l = 1 * new Date(); a = s.createElement(o)
        , m = s.getElementsByTagName(o)[0]; a.async = 1; a.src = g; m.parentNode.insertBefore(a, m)
    })(window, document, 'script', '//www.google-analytics.com/analytics.js', 'ga');

    ga('create','UA-1219467-34', 'auto');
ga('create', 'UA-1219467-34', 'auto', 'subsite');

    ga('send', 'pageview');
ga('subsite.send', 'pageview', '/street-level/CasimirHams111522.aspx'); 


</script>

<!--[if lt IE 9]>
<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
<![endif]-->
</head>
<body class="freshwater-cleveland ch-street-level NewsItem no-masthead">
<div id="fb-root"></div>
<script type="text/javascript">
var facebookAppId = '148315665262637';
</script>
<form method="post" action="./CasimirHams111522.aspx" id="aspnetForm">
<div>
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="qy3OZUzy7pCw45X4ZRdLmMLtLCsG9RstdEE9/Jhx/JubljJQtopRbR0IfemoNTktigbjqn+SRrgQnOgBSeLB60jC4To=" />
</div>
<div class="container-fluid page-container ">
<div class="container-fluid headerSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="header">
<nav class="top-nav navbar navbar-inverse navbar-fixed-top">
<div class="container">
<div class="navbar-header">
<div class="navbar-header-wrapper">
<ul class="nav navbar-nav focus-nav hidden-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Focus Areas<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/focusareas/people-of-cle.aspx'>#PeopleofCLE</a></li><li><a href='/focusareas/SreetsofCLE122221.aspx'>#StreetsofCLE</a></li><li><a href='/focusareas/artsandculture.aspx'>Arts + Culture</a></li><li><a href='/focusareas/ClevelandMasterworks122921.aspx'>Cleveland Masterworks</a></li><li><a href='/focusareas/connecting-the-dots.aspx'>Connecting the Dots</a></li><li><a href='/focusareas/CulinaryCrisis070920.aspx'>Culinary Crisis</a></li><li><a href='/focusareas/designbuild.aspx'>Design + Build</a></li><li><a href='/focusareas/diversity.aspx'>Diversity + Inclusion</a></li><li><a href='/focusareas/highereducation.aspx'>Education</a></li><li><a href='/focusareas/entrepreneurship.aspx'>Entrepreneurs + Innovators</a></li><li><a href='/focusareas/greenspace.aspx'>Green Space + Parks</a></li><li><a href='/focusareas/healthwellness.aspx'>Health + Wellness</a></li><li><a href='/focusareas/localfoodeconomy.aspx'>Local Food Economy</a></li><li><a href='/focusareas/movetocleveland.aspx'>Move to Cleveland</a></li><li><a href='/focusareas/OutdoorRecreation.aspx'>Outdoor Recreation</a></li><li><a href='/focusareas/placemaking-and-neighborhoods.aspx'>Placemaking + Neighborhoods</a></li><li><a href='/focusareas/RascalsandRogues.aspx'>Rascals and Rogues</a></li><li><a href='/focusareas/regionaleconomy.aspx'>Regional Economy</a></li><li><a href='/focusareas/socialinnovation.aspx'>Social Change</a></li><li><a href='/focusareas/sustainability.aspx'>Sustainability + Environment</a></li><li><a href='/focusareas/technology.aspx'>Technology</a></li><li><a href='/focusareas/transportation.aspx'>Transportation</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav subregion-nav hidden-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Neighborhoods<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/cities/Asia_Town/default.aspx'>AsiaTown/St. Clair Superior</a></li><li><a href='/cities/buckeye.aspx'>Buckeye</a></li><li><a href='/cities/campusdist/default.aspx'>Campus District</a></li><li><a href='/cities/central-kinsman.aspx'>Central/Kinsman</a></li><li><a href='/cities/clark-fulton.aspx'>Clark Fulton</a></li><li><a href='/cities/clevheights/default.aspx'>Cleveland Heights</a></li><li><a href='/cities/detshoreway/default.aspx'>Detroit Shoreway</a></li><li><a href='/cities/downtown/default.aspx'>Downtown</a></li><li><a href='/cities/edgewatercudell.aspx'>Edgewater & Cudell</a></li><li><a href='/cities/emerging_neighborhood/emerging_neighborhood.aspx'>Emerging Neighborhoods</a></li><li><a href='/cities/euclid.aspx'>Euclid</a></li><li><a href='/cities/fairfax.aspx'>Fairfax</a></li><li><a href='/cities/Garden-Valley.aspx'>Garden Valley</a></li><li><a href='/cities/glenville.aspx'>Glenville</a></li><li><a href='/cities/Goodrich-Kirtland-Park.aspx'>Goodrich-Kirtland Park</a></li><li><a href='/cities/Hough.aspx'>Hough</a></li><li><a href='/cities/la-villa-hispana.aspx'>La Villa Hispana</a></li><li><a href='/cities/lakewood/default.aspx'>Lakewood</a></li><li><a href='/cities/lilitaly/default.aspx'>Little Italy</a></li><li><a href='/cities/midtown/default.aspx'>MidTown</a></li><li><a href='/cities/MountPleasant.aspx'>Mount Pleasant</a></li><li><a href='/cities/ohiocity/default.aspx'>Ohio City</a></li><li><a href='/cities/oldbrooklyn.aspx'>Old Brooklyn</a></li><li><a href='/cities/playhousesq/default.aspx'>Playhouse Square</a></li><li><a href='/cities/shakerhts/default.aspx'>Shaker Heights</a></li><li><a href='/cities/shakersquarelarchmere.aspx'>Shaker Square & Larchmere</a></li><li><a href='/cities/ShortVincent.aspx'>Short Vincent</a></li><li><a href='/cities/slavicvillage.aspx'>Slavic Village</a></li><li><a href='/cities/stockyards.aspx'>Stockyards</a></li><li><a href='/cities/the-flats.aspx'>The Flats</a></li><li><a href='/cities/tremont/default.aspx'>Tremont</a></li><li><a href='/cities/Union-Miles.aspx'>Union Miles</a></li><li><a href='/cities/univcircle/default.aspx'>University Circle</a></li><li><a href='/cities/waterloo_collinwood/waterloocollinwood.aspx'>Waterloo & Collinwood</a></li><li><a href='/cities/kamms_corner/kammscorner.aspx'>West Park & Kamm's Corners</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav resources-nav hidden-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Stories<span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href='/stories'>All</a></li>
<li><a href='/features'>Features</a></li>
<li><a href='/breaking-ground'>Breaking Ground</a></li>
<li><a href='/street-level'>Street Level</a></li>
<li><a href='/inthenews'>Buzz</a></li>
<li role="separator" class="divider"></li>
<li class="dropdown-header">Archives</li>
<li><a href='/innovationnews'>Innovation News</a></li>
<li><a href='/devnews'>Development News</a></li>
</ul>
</li>
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="true">Series &amp; Events<span class="caret"></span></a>
<ul class="dropdown-menu multi-column columns-2">
<div class="row">
<div class="col-sm-6">
<ul class="multi-column-dropdown">
<li class="dropdown-header">Series</li>
<li><a href="/series/art-culture-connection.aspx">Art.Culture.Connection.</a></li>
<li><a href="/series/cle-means-we-advancing-equity-and-Inclusion-in-cleveland.aspx">CLE Means We</a></li>
<li><a href="/series/cleveland-clinic.aspx">Cleveland Clinic COVID-19</a></li>
<li><a href="/series/community-development-connection.aspx">Community Development Connection</a></li>
<li><a href="/series/connecting-the-dots.aspx">Connecting The Dots</a></li>
<li><a href="/series/BEL051722.aspx">Environmental Justice</a></li>
<li><a href="/series/first-suburbs-a-closer-look.aspx">First Suburbs: A Closer Look</a></li>
<li><a href="/series/fresh-faces.aspx">FreshFaces</a></li>
<li><a href="/series/global-cleveland.aspx">Global Cleveland</a></li>
<li><a href="/series/GrassrootsSuccess.aspx">Grassroots Success</a></li>
<li><a href="/series/may-dugan.aspx">May Dugan</a></li>
<li><a href="/series/microlending-success.aspx">Microlending Success</a></li>
<li><a href="/series/civics-essential-ohio.aspx">Ohio Civics Essential</a></li>
<li><a href="/series/on-the-ground.aspx">On The Ground</a></li>
<li><a href="/tags/taghome.aspx?tag=On+The+Ground%3a+Euclid">On The Ground: Euclid</a></li>
<li><a href="/tags/taghome.aspx?tag=On+The+Ground%3a+Fairfax">On The Ground: Fairfax</a></li>
<li><a href="/tags/taghome.aspx?tag=On+The+Ground%3a+La+Villa+Hispana">On The Ground: La Villa Hispana</a></li>
<li><a href="/tags/taghome.aspx?tag=On+The+Ground%3a+Old+Brooklyn">On The Ground: Old Brooklyn</a></li>
<li><a href="/series/people-planet-progress-a-decade-of-sustainable-cleveland.aspx">People, Planet, Progress</a></li>
<li><a href="/series/roots-of-change.aspx">Roots of Change</a></li>
<li><a href="/series/tools-for-talent.aspx">Tools for Talent</a></li>
</ul>
</div>
<div class="col-sm-6">
<ul class="multi-column-dropdown">
<li class="dropdown-header">Projects &amp; Events</li>
<li><a href="/events/">Cleveland’s Hottest Festivals - powered by CAC</a></li>
<li><a href="/sustainable-cleveland-projects/">Sustainable Cleveland Projects</a></li>
</ul>
</div>
</div>
</ul>
</li>
</ul>
<ul id="navbar-social" class="nav navbar-nav hidden-sm hidden-md hidden-lg">
<li>
<a href="https://www.facebook.com/pages/Fresh-Water-Cleveland/110757058984873?v=app_2309869772" target="_blank" title=""><img src="/images/facebook_on.png" alt="Facebook" /></a>
<a href="https://twitter.com/FreshWaterCLE" target="_blank"><img src="/images/twitter_on.png" alt="Twitter" /></a>
<a href="https://www.linkedin.com/company/freshwater-cleveland/" target="_blank"><img src="/images/linkedin_on.png" alt="LinkedIn" /></a>
<a href="https://www.instagram.com/freshwatercle/" target="_blank"><img src="/images/instagram_on.png" /></a>
<a type="application/rss+xml" rel="alternate" title="Subscribe to the Freshwater Cleveland RSS feed!" target="_blank" href="https://feeds.feedburner.com/FreshwaterCleveland"><img src="/images/rss_on.png" alt="RSS Feed" /></a>
<a class="search" href="#" onclick="$('.searchContainer').fadeToggle(); $('#q').focus(); return false;"><img src="/images/icon_search.png" /></a>
<div class="searchContainer"><input class="searchBox" id="q" name="q" type="text" onkeydown="return SubmitOnEnter(this,event,'');" /></div>
</li>
</ul>
</div>
<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".navbar-mobile" aria-expanded="false" aria-controls="navbar-top">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<div class="navbar-logo"><a href="/"><img class="image-logo" src="/images/logo-freshwater.png" alt="Freshwater Cleveland" /></a></div>
</div>
<div class="nav navbar-nav navbar-mobile collapse navbar-collapse">
<ul class="nav navbar-nav focus-nav visible-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Focus Areas<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/focusareas/people-of-cle.aspx'>#PeopleofCLE</a></li><li><a href='/focusareas/SreetsofCLE122221.aspx'>#StreetsofCLE</a></li><li><a href='/focusareas/artsandculture.aspx'>Arts + Culture</a></li><li><a href='/focusareas/ClevelandMasterworks122921.aspx'>Cleveland Masterworks</a></li><li><a href='/focusareas/connecting-the-dots.aspx'>Connecting the Dots</a></li><li><a href='/focusareas/CulinaryCrisis070920.aspx'>Culinary Crisis</a></li><li><a href='/focusareas/designbuild.aspx'>Design + Build</a></li><li><a href='/focusareas/diversity.aspx'>Diversity + Inclusion</a></li><li><a href='/focusareas/highereducation.aspx'>Education</a></li><li><a href='/focusareas/entrepreneurship.aspx'>Entrepreneurs + Innovators</a></li><li><a href='/focusareas/greenspace.aspx'>Green Space + Parks</a></li><li><a href='/focusareas/healthwellness.aspx'>Health + Wellness</a></li><li><a href='/focusareas/localfoodeconomy.aspx'>Local Food Economy</a></li><li><a href='/focusareas/movetocleveland.aspx'>Move to Cleveland</a></li><li><a href='/focusareas/OutdoorRecreation.aspx'>Outdoor Recreation</a></li><li><a href='/focusareas/placemaking-and-neighborhoods.aspx'>Placemaking + Neighborhoods</a></li><li><a href='/focusareas/RascalsandRogues.aspx'>Rascals and Rogues</a></li><li><a href='/focusareas/regionaleconomy.aspx'>Regional Economy</a></li><li><a href='/focusareas/socialinnovation.aspx'>Social Change</a></li><li><a href='/focusareas/sustainability.aspx'>Sustainability + Environment</a></li><li><a href='/focusareas/technology.aspx'>Technology</a></li><li><a href='/focusareas/transportation.aspx'>Transportation</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav subregion-nav visible-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Neighborhoods<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/cities/Asia_Town/default.aspx'>AsiaTown/St. Clair Superior</a></li><li><a href='/cities/buckeye.aspx'>Buckeye</a></li><li><a href='/cities/campusdist/default.aspx'>Campus District</a></li><li><a href='/cities/central-kinsman.aspx'>Central/Kinsman</a></li><li><a href='/cities/clark-fulton.aspx'>Clark Fulton</a></li><li><a href='/cities/clevheights/default.aspx'>Cleveland Heights</a></li><li><a href='/cities/detshoreway/default.aspx'>Detroit Shoreway</a></li><li><a href='/cities/downtown/default.aspx'>Downtown</a></li><li><a href='/cities/edgewatercudell.aspx'>Edgewater & Cudell</a></li><li><a href='/cities/emerging_neighborhood/emerging_neighborhood.aspx'>Emerging Neighborhoods</a></li><li><a href='/cities/euclid.aspx'>Euclid</a></li><li><a href='/cities/fairfax.aspx'>Fairfax</a></li><li><a href='/cities/Garden-Valley.aspx'>Garden Valley</a></li><li><a href='/cities/glenville.aspx'>Glenville</a></li><li><a href='/cities/Goodrich-Kirtland-Park.aspx'>Goodrich-Kirtland Park</a></li><li><a href='/cities/Hough.aspx'>Hough</a></li><li><a href='/cities/la-villa-hispana.aspx'>La Villa Hispana</a></li><li><a href='/cities/lakewood/default.aspx'>Lakewood</a></li><li><a href='/cities/lilitaly/default.aspx'>Little Italy</a></li><li><a href='/cities/midtown/default.aspx'>MidTown</a></li><li><a href='/cities/MountPleasant.aspx'>Mount Pleasant</a></li><li><a href='/cities/ohiocity/default.aspx'>Ohio City</a></li><li><a href='/cities/oldbrooklyn.aspx'>Old Brooklyn</a></li><li><a href='/cities/playhousesq/default.aspx'>Playhouse Square</a></li><li><a href='/cities/shakerhts/default.aspx'>Shaker Heights</a></li><li><a href='/cities/shakersquarelarchmere.aspx'>Shaker Square & Larchmere</a></li><li><a href='/cities/ShortVincent.aspx'>Short Vincent</a></li><li><a href='/cities/slavicvillage.aspx'>Slavic Village</a></li><li><a href='/cities/stockyards.aspx'>Stockyards</a></li><li><a href='/cities/the-flats.aspx'>The Flats</a></li><li><a href='/cities/tremont/default.aspx'>Tremont</a></li><li><a href='/cities/Union-Miles.aspx'>Union Miles</a></li><li><a href='/cities/univcircle/default.aspx'>University Circle</a></li><li><a href='/cities/waterloo_collinwood/waterloocollinwood.aspx'>Waterloo & Collinwood</a></li><li><a href='/cities/kamms_corner/kammscorner.aspx'>West Park & Kamm's Corners</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav resources-nav visible-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Stories<span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href='/stories'>All</a></li>
<li><a href='/features'>Features</a></li>
<li><a href='/breaking-ground'>Breaking Ground</a></li>
<li><a href='/street-level'>Street Level</a></li>
<li><a href='/inthenews'>Buzz</a></li>
<li role="separator" class="divider"></li>
<li class="dropdown-header">Archives</li>
<li><a href='/innovationnews'>Innovation News</a></li>
<li><a href='/devnews'>Development News</a></li>
</ul>
</li>
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="true">Series &amp; Events<span class="caret"></span></a>
<ul class="dropdown-menu multi-column columns-2">
<div class="row">
<div class="col-sm-6">
<ul class="multi-column-dropdown">
<li class="dropdown-header">Series</li>
<li><a href="/series/art-culture-connection.aspx">Art.Culture.Connection.</a></li>
<li><a href="/series/cle-means-we-advancing-equity-and-Inclusion-in-cleveland.aspx">CLE Means We</a></li>
<li><a href="/series/cleveland-clinic.aspx">Cleveland Clinic COVID-19</a></li>
<li><a href="/series/community-development-connection.aspx">Community Development Connection</a></li>
<li><a href="/series/connecting-the-dots.aspx">Connecting The Dots</a></li>
<li><a href="/series/BEL051722.aspx">Environmental Justice</a></li>
<li><a href="/series/first-suburbs-a-closer-look.aspx">First Suburbs: A Closer Look</a></li>
<li><a href="/series/fresh-faces.aspx">FreshFaces</a></li>
<li><a href="/series/global-cleveland.aspx">Global Cleveland</a></li>
<li><a href="/series/GrassrootsSuccess.aspx">Grassroots Success</a></li>
<li><a href="/series/may-dugan.aspx">May Dugan</a></li>
<li><a href="/series/microlending-success.aspx">Microlending Success</a></li>
<li><a href="/series/civics-essential-ohio.aspx">Ohio Civics Essential</a></li>
<li><a href="/series/on-the-ground.aspx">On The Ground</a></li>
<li><a href="/tags/taghome.aspx?tag=On+The+Ground%3a+Euclid">On The Ground: Euclid</a></li>
<li><a href="/tags/taghome.aspx?tag=On+The+Ground%3a+Fairfax">On The Ground: Fairfax</a></li>
<li><a href="/tags/taghome.aspx?tag=On+The+Ground%3a+La+Villa+Hispana">On The Ground: La Villa Hispana</a></li>
<li><a href="/tags/taghome.aspx?tag=On+The+Ground%3a+Old+Brooklyn">On The Ground: Old Brooklyn</a></li>
<li><a href="/series/people-planet-progress-a-decade-of-sustainable-cleveland.aspx">People, Planet, Progress</a></li>
<li><a href="/series/roots-of-change.aspx">Roots of Change</a></li>
<li><a href="/series/tools-for-talent.aspx">Tools for Talent</a></li>
</ul>
</div>
<div class="col-sm-6">
<ul class="multi-column-dropdown">
<li class="dropdown-header">Projects &amp; Events</li>
<li><a href="/events/">Cleveland’s Hottest Festivals - powered by CAC</a></li>
<li><a href="/sustainable-cleveland-projects/">Sustainable Cleveland Projects</a></li>
</ul>
</div>
</div>
</ul>
</li>
</ul>
</div>
<div id="navbar-secondary" class="collapse navbar-collapse navbar-mobile">
<ul class="nav navbar-nav navbar-general">
<li class="active"><a href="/about/about.aspx" class="nav-about">About</a></li>
<li><a href="/about/contactus.aspx" class="nav-contact">Contact</a></li>
</ul>
<ul id="navbar-social" class="nav navbar-nav hidden-xs">
<li>
<a href="https://www.facebook.com/pages/Fresh-Water-Cleveland/110757058984873?v=app_2309869772" target="_blank" title=""><img src="/images/facebook_on.png" alt="Facebook" /></a>
<a href="https://twitter.com/FreshWaterCLE" target="_blank"><img src="/images/twitter_on.png" alt="Twitter" /></a>
<a href="https://www.linkedin.com/company/freshwater-cleveland/" target="_blank"><img src="/images/linkedin_on.png" alt="LinkedIn" /></a>
<a href="https://www.instagram.com/freshwatercle/" target="_blank"><img src="/images/instagram_on.png" /></a>
<a type="application/rss+xml" rel="alternate" title="Subscribe to the Freshwater Cleveland RSS feed!" target="_blank" href="https://feeds.feedburner.com/FreshwaterCleveland"><img src="/images/rss_on.png" alt="RSS Feed" /></a>
<a class="search" href="#" onclick="$('.searchContainer').fadeToggle(); $('#q').focus(); return false;"><img src="/images/icon_search.png" /></a>
<div class="searchContainer"><input class="searchBox" id="q" name="q" type="text" onkeydown="return SubmitOnEnter(this,event,'');" /></div>
</li>
</ul>
</div>
</div>
</nav>
</div>
</div>
</div>
<div class="container-fluid contentSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="container container-main">
<div class="row">
<div class="col-md-12 page-heading">
<h1 class="page-title">St. Casimir Church, community make sure Willson School families have holiday dinners</h1>
<div class="byline">
<span class="author">Karin Connelly Rice</span> |
<span class="date">Tuesday, November 15, 2022</span>
</div>
<div class="contentMeta">
<div class="share">
<span class="shareText">Share</span>
<span class="buttons">
<a class="shareFacebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fwww.freshwatercleveland.com%2fstreet-level%2fCasimirHams111522.aspx" onclick="ga('send','social','facebook','send','/street-level/CasimirHams111522.aspx');"><img src="/images/share_facebook.png" alt="Share on Facebook" /></a>
<a class="shareTwitter" target="_blank" href="https://twitter.com/share?url=https%3a%2f%2fwww.freshwatercleveland.com%2fstreet-level%2fCasimirHams111522.aspx&amp;text=St.+Casimir+Church%2c+community+make+sure+Willson+School+families+have+holiday+dinners" onclick="ga('send','social','twitter','send','/street-level/CasimirHams111522.aspx');"><img src="/images/share_twitter.png" alt="Share on Twitter" /></a>
<a class="shareLinkedin" target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3a%2f%2fwww.freshwatercleveland.com%2fstreet-level%2fCasimirHams111522.aspx&amp;title=St.+Casimir+Church%2c+community+make+sure+Willson+School+families+have+holiday+dinners" onclick="ga('send','social','linkedin','send','/street-level/CasimirHams111522.aspx');"><img src="/images/share_linkedin.png" alt="Share on LinkedIn" /></a>
<a class="shareMailto" href="/cdn-cgi/l/email-protection#5b6419343f2266332f2f2b287e683a7e693d7e693d2c2c2c753d293e28332c3a2f3e2938373e2d3e373a353f753834367e693d282f293e3e2f76373e2d3e377e693d183a2832363229133a36286a6a6a6e6969753a282b237d3a362b60082e39313e382f6608333a293e61082f7570183a28323632297018332e2938337e693870383436362e35322f2270363a303e70282e293e700c32373728343570083833343437703d3a363237323e2870333a2d3e70333437323f3a22703f3235353e2928" onclick="ga('send','social','email','send','/street-level/CasimirHams111522.aspx');"><img src="/images/share_email.png" alt="Share through Email" /></a></span>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
        </script>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-md-8">
<div class="content-block">
<div class="featuredImage">
<div class="overlay"></div>
<div id="ctl00_ContentPlaceHolder1_ctl02" class="mediaGallery caption-below mode-lazy featured-media-gallery">
<div class="carousel carousel-main" data-flickity='{ "cellAlign":"left", "contain": true, "wrapAround": true, "autoPlay": false, "pauseAutoPlayOnHover": true, "fullscreen": true, "fade": true, "adaptiveHeight": true, "imagesLoaded": true, "lazyLoad":true, "cellSelector": ".carousel-cell", "setGallerySize": true, "prevNextButtons": true, "pageDots": false }'>
<div class="carousel-cell">
<div class=" cell-item">
<div class="carousel-image-container">
<img class="carousel-image " alt="St. Casimir Church Hams for Fams" sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px" data-flickity-lazyload-srcset="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=t 120w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=l 265w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=lf 500w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=f 750w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=m 980w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=p 1125w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=mx 1600w" data-flickity-lazyload-src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg" />
<noscript>
 <img class="carousel-image "
      alt="St. Casimir Church Hams for Fams"
      sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px"
      srcset="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=t 120w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=l 265w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=lf 500w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=f 750w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=m 980w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=p 1125w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=mx 1600w"
      src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg"
     />
 </noscript>
</div>
<div class="captionOverlay"><div class="captionText">St. Casimir Church Hams for Fams <span class='image-credits'>Courtesy of St. Casimir Church</span></div></div>
</div>
</div>
<div class="carousel-cell">
<div class=" cell-item">
<div class="carousel-image-container image-vertical">
<img class="carousel-image " alt="St. Casimir Church Hams for Fams" sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px" data-flickity-lazyload-srcset="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=t 120w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=l 265w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=lf 500w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=f 750w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=m 980w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=p 1125w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=mx 1600w" data-flickity-lazyload-src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg" />
<noscript>
 <img class="carousel-image "
      alt="St. Casimir Church Hams for Fams"
      sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px"
      srcset="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=t 120w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=l 265w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=lf 500w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=f 750w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=m 980w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=p 1125w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=mx 1600w"
      src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg"
     />
 </noscript>
</div>
<div class="captionOverlay"><div class="captionText">St. Casimir Church Hams for Fams <span class='image-credits'>Courtesy of St. Casimir Church</span></div></div>
</div>
</div>
<div class="carousel-cell">
<div class=" cell-item">
<div class="carousel-image-container image-vertical">
<img class="carousel-image " alt="St. Casimir Church Hams for Fams" sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px" data-flickity-lazyload-srcset="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=t 120w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=l 265w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=lf 500w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=f 750w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=m 980w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=p 1125w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=mx 1600w" data-flickity-lazyload-src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg" />
<noscript>
 <img class="carousel-image "
      alt="St. Casimir Church Hams for Fams"
      sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px"
      srcset="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=t 120w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=l 265w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=lf 500w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=f 750w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=m 980w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=p 1125w, /galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=mx 1600w"
      src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg"
     />
 </noscript>
</div>
<div class="captionOverlay"><div class="captionText">St. Casimir Church Hams for Fams <span class='image-credits'>Courtesy of St. Casimir Church</span></div></div>
</div>
</div>
</div>
<div class="carousel carousel-thumbs" data-flickity='{ "asNavFor": "#ctl00_ContentPlaceHolder1_ctl02 .carousel-main", "cellAlign":"center", "contain": true, "autoPlay": false, "fullscreen": false, "fade": false, "adaptiveHeight": true, "imagesLoaded": true, "lazyLoad": true, "cellSelector": ".carousel-cell", "setGallerySize": false, "prevNextButtons": false, "pageDots": false }'>
<div class="carousel-cell">
<img class="carousel-image lazy-load " data-src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=l" alt="Thumbnail image" />
<noscript>
 <img class="carousel-image "
      src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_02.jpg?s=l"
      alt="Thumbnail image"
     />
 </noscript>
</div>
<div class="carousel-cell">
<img class="carousel-image lazy-load " data-src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=l" alt="Thumbnail image" />
<noscript>
 <img class="carousel-image "
      src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=l"
      alt="Thumbnail image"
     />
 </noscript>
</div>
<div class="carousel-cell">
<img class="carousel-image lazy-load " data-src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=l" alt="Thumbnail image" />
<noscript>
 <img class="carousel-image "
      src="/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_03.jpg?s=l"
      alt="Thumbnail image"
     />
 </noscript>
</div>
</div>
<div class="clear"></div>
</div>
</div>
<div class="leaderboard">

<div class="adzone " id="ctl00_ContentPlaceHolder1_MastHeadAdZone">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Masthead Leaderboard');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=3c439a62c75d431baa1916ef42740a65&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6863&amp;cb=25960605929&amp;n=3c439a62c75d431baa1916ef42740a65&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="body">
The congregation at <a href="https://www.stcasimir.com/" target="_blank">St. Casimir Church</a> in the St. Clair Superior neighborhood tends to make sure their neighbors are taken care of. And church volunteer John Niedzialek&mdash;owner of <span style="background:white"><a href="https://www.freshwatercleveland.com/breaking-ground/CasmirCat020320.aspx" target="_blank">Casimir the Weather-predicting Cat</a>, and neighborhood <a href="https://www.freshwatercleveland.com/street-level/CCSDumping051121.aspx" target="_blank">watchdog and organizer</a>&mdash;is now leading the way in making sure the students and their families at nearby <a href="https://www.clevelandmetroschools.org/willson" target="_blank">Willson School</a> on Ansel Road will celebrate Thanksgiving and Christmas with full stomachs. </span><br>
<br>
<span style="background:white"><span class="content-image-left content-image-no-border"><noscript><img src="https://www.freshwatercleveland.com/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg" srcset="https://www.freshwatercleveland.com/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=l 265w, https://www.freshwatercleveland.com/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=lf 500w" sizes="(min-width:570px) 265px, (min-width:300px) 500px, 265px"></noscript><img data-src="https://www.freshwatercleveland.com/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg" class="lazy-load" data-srcset="https://www.freshwatercleveland.com/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=l 265w, https://www.freshwatercleveland.com/galleries/2022/November_2022/Issue_543/st-casimir--hams_for_fams_01.jpg?s=lf 500w" data-sizes="(min-width:570px) 265px, (min-width:300px) 500px, 265px"><span class="content-image-text">St. Casimir Church Hams for Fams</span></span>For the second year, Niedzialek and other church and community volunteers are raising money to buy hams to distribute next week at the school. &#8220;</span>Our congregation is very small,&#8221; says Niedzialek, &#8220;but you do what you can&nbsp;do.&#8221;<br>
<br>
Niedzialek says he is aware that there a lot of families in need at Willson, so last year he got the idea to pass out hams and started a fundraising campaign. It was so successful, the congregation decided to do it again for Easter this year and is now doing it for the winter holidays.<br>
<br>
&#8220;Last year was the first year we did it, so of course we want to make it bigger this year,&#8221; he says. &#8220;We gave out about 25 hams for Christmas&nbsp;and also 25 for Easter last year. They all go to Willson School, as it is right next to the church, and we have a relationship with them.&#8221;<br>
<br>
Niedzialek says the teachers help choose the families who can benefit most and distribute the hams accordingly on the last day of school before break, next Tuesday, Nov. 22 for Thanksgiving and Friday, Dec. 16 for the winter holidays.<br>
<br>
Niedzialek says he simply runs a grassroots fundraising campaign&mdash;asking church members and the community for donations. He then researches the best prices for hams and purchases them at the best-priced store.<br>
<br>
&#8220;I get the funds by sending out an email and texts to the congregation and friends,&#8221; he explains. &#8220;Whatever I get I divide by two for Thanksgiving and Christmas. Then I go out and try to find some nice hams. I found some good ones last year at Aldi, but they usually have a limit, so I go to several stores on several days to get the best bang for the buck.&#8221;<br>
<br>
This year, he says he&#8217;s now researching how he could also supply the families with a vegetable. &nbsp;&#8220;I&#8217;m trying&nbsp;to find a vegetable&nbsp;vendor at a market to get a good price for Yams this year so we can have Hams and Yams for Fams,&#8221; he quips.<br>
<br>
Niedzialek is still collecting donations for this year&#8217;s campaign. Anyone wishing to donate can <a href="/cdn-cgi/l/email-protection#660c090e0848080f03021c0f070a030d26010b070f0a4805090b">email Niedzialek</a> or text him at (440) 749-7415.
</div>
<div class="clear"></div>
<div class="contentMeta">
<div class="share">
<span class="shareText">Share</span>
<span class="buttons">
<a class="shareFacebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fwww.freshwatercleveland.com%2fstreet-level%2fCasimirHams111522.aspx" onclick="ga('send','social','facebook','send','/street-level/CasimirHams111522.aspx');"><img src="/images/share_facebook.png" alt="Share on Facebook" /></a>
<a class="shareTwitter" target="_blank" href="https://twitter.com/share?url=https%3a%2f%2fwww.freshwatercleveland.com%2fstreet-level%2fCasimirHams111522.aspx&amp;text=St.+Casimir+Church%2c+community+make+sure+Willson+School+families+have+holiday+dinners" onclick="ga('send','social','twitter','send','/street-level/CasimirHams111522.aspx');"><img src="/images/share_twitter.png" alt="Share on Twitter" /></a>
<a class="shareLinkedin" target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3a%2f%2fwww.freshwatercleveland.com%2fstreet-level%2fCasimirHams111522.aspx&amp;title=St.+Casimir+Church%2c+community+make+sure+Willson+School+families+have+holiday+dinners" onclick="ga('send','social','linkedin','send','/street-level/CasimirHams111522.aspx');"><img src="/images/share_linkedin.png" alt="Share on LinkedIn" /></a>
<a class="shareMailto" href="/cdn-cgi/l/email-protection#fcc3be939885c19488888c8fd9cf9dd9ce9ad9ce9a8b8b8bd29a8e998f948b9d88998e9f90998a99909d9298d29f9391d9ce9a8f888e999988d190998a9990d9ce9abf9d8f9591958eb49d918fcdcdcdc9ceced29d8f8c84da9d918cc7af899e96999f88c1af949d8e99c6af88d2d7bf9d8f9591958ed7bf94898e9f94d9ce9fd79f9391918992958885d7919d9799d78f898e99d7ab9590908f9392d7af9f94939390d79a9d91959095998fd7949d8a99d794939095989d85d798959292998e8f" onclick="ga('send','social','email','send','/street-level/CasimirHams111522.aspx');"><img src="/images/share_email.png" alt="Share through Email" /></a></span>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
        </script>
</div>
<div class="toolBar">
<div class="toolBarLike">
<div id="fb-like" class="fb-like" data-href="https://www.freshwatercleveland.com/street-level/CasimirHams111522.aspx" data-width="" data-layout="button_count" data-action="like" data-size="small" data-share="false"></div>
<script>facebookComponents.register('fb-like');</script>
</div>
</div>
</div>
<div class="authorSection">
<div class="author abstractItem clearfix ">
<div class="content">
<img class="" style="border:0px" src="/galleries/karinfla.jpg" alt="" />
<h2>Read more articles by <a target='' href='/authors/karinconnelly.aspx'>Karin Connelly Rice</a>.</h2>
<a href="/cdn-cgi/l/email-protection#a5cec4d7cccbe5c3d7c0d6cdd2c4d1c0d7c6c9c0d3c0c9c4cbc18bc6cac8">Karin Connelly Rice</a>&nbsp;enjoys telling people&#39;s stories, whether it&#39;s a promising startup or a life&#39;s passion. Over the past 20 years she has reported on the local business community for publications such as <em>Inside Business</em> and <em>Cleveland Magazine</em>. She was editor of the Rocky River/Lakewood edition of <em>In the Neighborhood</em> and was a reporter and photographer for the <em>Amherst News-Times</em>. At Fresh Water she enjoys telling the stories of Clevelanders who are shaping and embracing the business and research climate in Cleveland.
</div>
</div>
<div class="clear"></div>
</div>
<div class="contentMeta">
<div class="relatedContent">
<h4>Related Tags</h4>
<div class="tags separator">
<a title="View more stories related to Grassroots Success" href="/tags/taghome.aspx?tag=Grassroots+Success">Grassroots Success</a>, <a title="View more stories related to Regional Economy" href="/tags/taghome.aspx?tag=Regional+Economy">Regional Economy</a>&nbsp;
</div>
</div>
</div>
<div id="commentsContainer" class="commentsContainer">
<a name="comments"></a>
<div id="fb-comments" class="fb-comments" data-href="https://www.freshwatercleveland.com/street-level/CasimirHams111522.aspx" data-width="560" data-numposts="100"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
facebookComponents.register('fb-comments');
</script>
</div>
<div class="leaderboard">

<div class="adzone " id="ctl00_ContentPlaceHolder1_ctl07">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Leaderboard 2');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=7a0f3a13da5c44c693d6ddc1a459d6d0&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6872&amp;cb=25960605929&amp;n=7a0f3a13da5c44c693d6ddc1a459d6d0&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="leaderboard">

<div class="adzone " id="ctl00_ContentPlaceHolder1_ctl08">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Leaderboard 3');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=bb04195c4c0a476e875215044a4efc01&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6873&amp;cb=25960605929&amp;n=bb04195c4c0a476e875215044a4efc01&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
</div>
<div class="col-xs-12 col-md-4">
<div class="row">
<div class="col-xs-12">
<div class="columnList partnerLinks">
<h3>Recommended Content</h3>
<div class="clearfix">
<div>

<div class="adzone clearfix" id="ctl00_ContentPlaceHolder1_AdZonePartnerLinks_ctl00">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle Html 1');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=db0e5eb830c7411cb19903767cfd074d&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6864&amp;cb=25960605929&amp;n=db0e5eb830c7411cb19903767cfd074d&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>

<div class="adzone clearfix" id="ctl00_ContentPlaceHolder1_AdZonePartnerLinks_ctl01">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle Html 2');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=e8c938a230684c2eb3096f9afeadfd79&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6865&amp;cb=25960605929&amp;n=e8c938a230684c2eb3096f9afeadfd79&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>

<div class="adzone clearfix" id="ctl00_ContentPlaceHolder1_AdZonePartnerLinks_ctl02">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle Html 3');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=225b1039d8de462e8c949caebc750741&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6866&amp;cb=25960605929&amp;n=225b1039d8de462e8c949caebc750741&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
<script type="text/javascript">InitializePartnerLinks();</script>
</div>
<div class="towerad-container">

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone6">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 1');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=81a7885fa30e4ee29112d4fe62fff90d&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6867&amp;cb=25960605929&amp;n=81a7885fa30e4ee29112d4fe62fff90d&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
 <div class="towerad-container">

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone2">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 2');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=382ccdc355a64bc78eb828d9c7005960&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6868&amp;cb=25960605929&amp;n=382ccdc355a64bc78eb828d9c7005960&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="towerad-container">

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone9">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 3');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=39e8d580bb7d4099b065d10b11e00fad&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6869&amp;cb=25960605929&amp;n=39e8d580bb7d4099b065d10b11e00fad&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
<div class="col-xs-12">
</div>
<div class="col-xs-12 hidden-xs hidden-sm">
<div id="ctl00_ContentPlaceHolder1_PopularPages_PopularPagesAjaxContainer"></div>
<script type="text/javascript">
//<![CDATA[
    $("#ctl00_ContentPlaceHolder1_PopularPages_PopularPagesAjaxContainer").load("/Controls/TopPages.aspx?numberOfPages=10&preTitle=Top+&title=Stories&maxPageTitleLength=-1&pathFilterStartsWith=%2froot&windowLengthInDays=14&cacheKey=IssueMediaGroup.PopularPages.Stories&cacheExpirationMinutes=0&removeEntriesPriorToWindowStart=False&cssClass=&listCssClass=&baseDirectoryPath=%2froot%2fstories&adZoneName=&abstractOnFirst=False #popularPageContainer");
//]]>
</script>
<script type="text/javascript">IMG_axs('pv', '85f9cd2e-a95c-4f7a-b462-74cff743907e');</script>
</div>
<div class="col-xs-12">
<div class="towerad-container">

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone5">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 4');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=5de0160abf514cc19a22f9b3c3293d17&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6870&amp;cb=25960605929&amp;n=5de0160abf514cc19a22f9b3c3293d17&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone12">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 5');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=0ba0663b82114ea89d27d45bb6bbcf0d&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=6871&amp;cb=25960605929&amp;n=0ba0663b82114ea89d27d45bb6bbcf0d&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12 hidden-xs hidden-sm">
<div class="columnList network horizontal">
<h3>
Across Our Network
</h3>
<div class="clearfix">
<div>
<ul class="textWrapList noBullets">
<li>
<div class="listImage thumb">
<a href="https://www.inputfortwayne.com/features/voter-engagement.aspx" target="_blank">
<noscript><img src="https://www.inputfortwayne.com/galleries/v3_2.jpg?s=l" class="thumb"></noscript>
<img data-src="https://www.inputfortwayne.com/galleries/v3_2.jpg?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.inputfortwayne.com/features/voter-engagement.aspx" target="_blank">Why vote in midterms, & who’s on the ballot? These resources seek to boost voter turnout & education</a>
<div id="ctl00_ContentPlaceHolder1_ctl11_RepeaterColumns_ctl01_Div1" class="additionalattribute">
Source: Input Fort Wayne
</div>
<div class="clear"></div>
</li>
<li>
<div class="listImage thumb">
<a href="https://www.secondwavemedia.com/lakeshore/features/Grand_Haven_annual_sand_sculpture_contest_returns.aspx" target="_blank">
<noscript><img src="https://www.secondwavemedia.com/lakeshore/images/sandcastle.jpg?s=l" class="thumb"></noscript>
<img data-src="https://www.secondwavemedia.com/lakeshore/images/sandcastle.jpg?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.secondwavemedia.com/lakeshore/features/Grand_Haven_annual_sand_sculpture_contest_returns.aspx" target="_blank">Grand Haven’s annual sand sculpture returns after hiatus</a>
<div id="ctl00_ContentPlaceHolder1_ctl11_RepeaterColumns_ctl02_Div1" class="additionalattribute">
Source: The Lakeshore
</div>
<div class="clear"></div>
</li>
<li>
<div class="listImage thumb">
<a href="https://www.secondwavemedia.com/features/racismpublichealthcrisis07282022.aspx" target="_blank">
<noscript><img src="https://www.secondwavemedia.com/galleries/stateofhealth/bbs_5887.jpeg?s=l" class="thumb"></noscript>
<img data-src="https://www.secondwavemedia.com/galleries/stateofhealth/bbs_5887.jpeg?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.secondwavemedia.com/features/racismpublichealthcrisis07282022.aspx" target="_blank">Nearly 20 Michigan communities have declared racism a public health crisis. What happens next?</a>
<div id="ctl00_ContentPlaceHolder1_ctl11_RepeaterColumns_ctl03_Div1" class="additionalattribute">
Source: Second Wave Michigan
</div>
<div class="clear"></div>
</li>
<li>
<div class="listImage thumb">
<a href="https://www.secondwavemedia.com/concentrate/features/arpaviolenceintervention0646.aspx" target="_blank">
<noscript><img src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_646/billy-cole-jeannette-hadden-bryan-foley-01-1600.jpg?s=l" class="thumb"></noscript>
<img data-src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_646/billy-cole-jeannette-hadden-bryan-foley-01-1600.jpg?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.secondwavemedia.com/concentrate/features/arpaviolenceintervention0646.aspx" target="_blank">Ypsi-based nonprofits receive county grants for community violence intervention</a>
<div id="ctl00_ContentPlaceHolder1_ctl11_RepeaterColumns_ctl04_Div1" class="additionalattribute">
Source: Concentrate
</div>
<div class="clear"></div>
</li>
 </ul>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="container-fluid contentSection2 no-padding">
<div class="container-fluid container-inner no-padding">
</div>
</div>
<div class="container-fluid footerAdsSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="container">
<div class="byline">Sponsored By</div>
<div id="footeradholder">
<div id="row" class="row">
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone1">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 01');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=233474046cee4a779bea689665541591&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=234&amp;cb=25960605929&amp;n=233474046cee4a779bea689665541591&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone2">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 02');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=0442918a98ed4660b1a25ce921724ef7&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=235&amp;cb=25960605929&amp;n=0442918a98ed4660b1a25ce921724ef7&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone3">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 03');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=2204703bdb7246378fc7374685f7326a&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=236&amp;cb=25960605929&amp;n=2204703bdb7246378fc7374685f7326a&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone4">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 04');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=9a470b8bfc994b5b90fbac6e058f1074&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=237&amp;cb=25960605929&amp;n=9a470b8bfc994b5b90fbac6e058f1074&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone5">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 05');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=7085bc00e8df49f78189361a6920326a&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=238&amp;cb=25960605929&amp;n=7085bc00e8df49f78189361a6920326a&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone6">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 06');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=708e395dac564cd38e6410661f87d269&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=239&amp;cb=25960605929&amp;n=708e395dac564cd38e6410661f87d269&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
<div id="row" class="row">
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone7">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 07');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=b806b8286aee44ac95fa682e6535f746&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=240&amp;cb=25960605929&amp;n=b806b8286aee44ac95fa682e6535f746&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone8">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 08');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=f61f327ccdc64a7683661464f4b50beb&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=241&amp;cb=25960605929&amp;n=f61f327ccdc64a7683661464f4b50beb&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone9">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 09');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=e70f261c03514829b2ae7e1611994154&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=242&amp;cb=25960605929&amp;n=e70f261c03514829b2ae7e1611994154&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone10">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 10');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=37a139cbb862429ba4a256ec58fb6aa3&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=243&amp;cb=25960605929&amp;n=37a139cbb862429ba4a256ec58fb6aa3&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone11">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 11');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=3da1bd50115d4d6896ace21690111436&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=244&amp;cb=25960605929&amp;n=3da1bd50115d4d6896ace21690111436&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone12">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 12');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=d7856981a6624bf2be16af9111c42c07&amp;cb=25960605929' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=6&amp;zoneid=245&amp;cb=25960605929&amp;n=d7856981a6624bf2be16af9111c42c07&amp;Page=6~%2fstreet-level%2fCasimirHams111522.aspx&amp;Tag=6%7eRegional+Economy%2c6%7eGrassroots+Success' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="container-fluid footerSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="container">
<div class="row">
<div class="col-sm-7 col-lg-6 footer-focus-areas">
Focus Areas
<ul><li><a href='/focusareas/people-of-cle.aspx'>#PeopleofCLE</a></li><li><a href='/focusareas/healthwellness.aspx'>Health + Wellness</a></li><li><a href='/focusareas/SreetsofCLE122221.aspx'>#StreetsofCLE</a></li><li><a href='/focusareas/localfoodeconomy.aspx'>Local Food Economy</a></li><li><a href='/focusareas/artsandculture.aspx'>Arts + Culture</a></li><li><a href='/focusareas/movetocleveland.aspx'>Move to Cleveland</a></li><li><a href='/focusareas/ClevelandMasterworks122921.aspx'>Cleveland Masterworks</a></li><li><a href='/focusareas/OutdoorRecreation.aspx'>Outdoor Recreation</a></li><li><a href='/focusareas/connecting-the-dots.aspx'>Connecting the Dots</a></li><li><a href='/focusareas/placemaking-and-neighborhoods.aspx'>Placemaking + Neighborhoods</a></li><li><a href='/focusareas/CulinaryCrisis070920.aspx'>Culinary Crisis</a></li><li><a href='/focusareas/RascalsandRogues.aspx'>Rascals and Rogues</a></li><li><a href='/focusareas/designbuild.aspx'>Design + Build</a></li><li><a href='/focusareas/regionaleconomy.aspx'>Regional Economy</a></li><li><a href='/focusareas/diversity.aspx'>Diversity + Inclusion</a></li><li><a href='/focusareas/socialinnovation.aspx'>Social Change</a></li><li><a href='/focusareas/highereducation.aspx'>Education</a></li><li><a href='/focusareas/sustainability.aspx'>Sustainability + Environment</a></li><li><a href='/focusareas/entrepreneurship.aspx'>Entrepreneurs + Innovators</a></li><li><a href='/focusareas/technology.aspx'>Technology</a></li><li><a href='/focusareas/greenspace.aspx'>Green Space + Parks</a></li><li><a href='/focusareas/transportation.aspx'>Transportation</a></li></ul>
</div>
<div class="col-sm-5 col-lg-2 footer-links">
<ul>
<li><a href="/about/About.aspx">About FreshWater</a></li>
<li><a href="/about/Links.aspx">Cleveland Links</a></li>
<li><a href="/about/ContactUs.aspx">Contact Us</a></li>
<li><a href="/about/Tips.aspx">Have a Tip?</a></li>
<li><a href="/about/newsletter-signup.aspx">Newsletter Signup</a></li>
<li><a href="/about/PrivacyPolicy.aspx">Privacy Policy</a></li>
<li><a href="/about/TermsOfUse.aspx">Terms of Use</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">Copyright &copy; Issue Media Group. All rights reserved.</div>
</div>
</div>
</div>
</div>
</div>
<script>
var pageInfo = {"article":true,"post_id":"85f9cd2e-a95c-4f7a-b462-74cff743907e","post_type":"News Item","taxonomies":{"tags":["Grassroots Success","Regional Economy"]},"url":"https://www.freshwatercleveland.com/street-level/CasimirHams111522.aspx"};
if (window.pico) {
    window.pico('visit', pageInfo);
}
</script>
<div>
<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="5BA95F45" />
</div></form>
<script src="https://cdnjs.cloudflare.com/ajax/libs/flickity/2.2.1/flickity.pkgd.min.js" integrity="sha256-3Maq7M1TC8sOke8B4gRkhfGtETqGWq+xenQO7k2mHjI=" crossorigin="anonymous"></script>
<script src="https://unpkg.com/flickity-fullscreen@1.1.1/fullscreen.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/vanilla-lazyload/17.3.0/lazyload.min.js"></script>
<script>
var lazyLoadInstance = new LazyLoad({
    elements_selector: ".lazy-load",
    callback_loaded: lazyloadCallback
});
</script>
</body>
</html>
